Messages

 
DISE for Riptide: Things that do not work well yet: weapon proficiency skills, maps, and possibly more.

Live chat: Sorry, I don't have the capacity to answer everyone timely at the moment. Please send e-mail instead.

If DISE is stuck trying to update, run this command in Command Prompt.

Friday, December 23, 2011

Release: Alpha 42

Thanks for all your suggestions and for reporting issues. Your patience as well. :)

Note: If you get this message saying this after updating, please don't worry about it:
"[...] dise.exe.updbak' couldn't be removed [...]"
The file was probably removed after all, and who knows why it says that it couldn't. The next version of DISE should suppress the message. You're more likely to see similar messages (even when nothing was wrong) due to logging in wxWidgets 2.9. :)

What's new
  • Updated wxWidgets to version 2.9.3.
  • Worked around a very strange issue where "0" somehow wasn't "0" (when it seemed to be, and it worked fine before). The issue just came out of nowhere, causing a crash when starting DISE and no update was found. Bug in wxWidgets or something else. Just strange.
  • Switched item condition slider (which didn't do anything anyway) with a text field because I haven't figured how to calculate the max condition. -1 = unbreakable/not used (usually firearms and other things).
  • Added button to randomize the "attributes" value.
  • Added some more tool tips (hover your mouse cursor over a text field, etc, to see info).
  • Minor changes.
Download
dise_alpha_42.zip

18 comments:

  1. I Love this program, best out there. Have had fun learning how the file structure works. Havent had any real problems that I couldnt figure out on my own, except some times ill add a weapon from the "que" (melee weapons at bottom of program) and ill go back to the game, and the states will all be 0. I can use the weapon but it does 1 hit damage. I have messed around with the new condition tool, and also took off items saved file, closed program, reopen, add weapon, save and replay, and still all 0's. Theres no damage bar for it as if it were a chainsaw. Iv gotten all of the weapons to work except the "home Run" i cant get this on my character with out all 0's. Help? Suggestions on how to get it ? also, does the shock pulse bombs show 0's for damage as well on everyone eles? iv tried making on and it shows 0.... confused. Any help I appreciate.

    ReplyDelete
  2. Thank you very much! It makes me very happy when people likes my work! :D

    My guess is that you may have changed the "attributes" to a value higher than the game uses. Seems like the game uses values up to 2147483647 or less.

    If it doesn't help, you may e-mail me your game-save so that I can check it out. :)

    ReplyDelete
  3. Iv tried Making One* and it shows 0, also the chainsaws i had a problem with, when my character holds it, it never starts up. Characters can hold it but does nothing. But im mainly worryed about the silly "home run" issue that im having...im running xp btw, idk if that would matter (i dont think it should)

    ReplyDelete
  4. I do most of my testing on Win7, but DISE should be fine on XP as well.

    I never got the chainsaw working, but I know someone did. You could try something like this:
    Copy the weapon from a different game-save, or experiment with the "attributes". Maybe try to make lots of chainsaws, then make random attributes or each of them them. :D

    ReplyDelete
  5. Maybe I misunderstood a bit. Some mods can apparently only be used for certain weapons. :(

    ReplyDelete
  6. I tried the changing of the attributes for the "home run" not to be confused with the developer mod "home run bat" .... ill have to send ya an email. Im going to see if i can drag and copy next..

    ReplyDelete
  7. Please do. I'll be able to check it out a bit later (I'm going to bed, actually). :)

    ReplyDelete
  8. i dont blame ya, me as well... laters merry christmas (if your in to that)

    ReplyDelete
  9. got it to work with the copy and paste, used a download off modio that someone had that had the bat i wanted... also just copyed the chainsaws over like you said.. and g2g, thanks for your time again.. always more then one way to skin a cat.

    ReplyDelete
  10. I'm glad! :)
    Also, thank you! You too! :)

    ReplyDelete
  11. Im seem to be getting a runtime error, how do i fix this ?

    ReplyDelete
  12. Please send me an e-mail with the details and possibly a screen shot of the message (or press Ctrl+C to copy he text, then paste it in the e-mail). Please include the exact steps to reproduce the issue (so that I can do the same). Thank you!. :)

    ReplyDelete
  13. Still crashes for me... prgm opens up but when i try to open a save file it crashes to window's generic... blabla has stopped working...oo yeah and if game save loc is set.. the prgm wont open unless i edit the HKEY as suggested.. thanks for all your hard work !

    ReplyDelete
  14. Hmm. Do you drag and drop the file into DISE, or do you use the menu (File>Open)?

    ReplyDelete
  15. Maybe it has something to do with the EXE packer I use (UPX).. If you send me an e-mail, I'll have multiple versions of DISE ready for you to try.

    ReplyDelete
  16. I use the menu, is that not the way to do it ?

    ReplyDelete
  17. You can try to drag and drop the file into DISE.

    The more specific the steps are to reproduce the problem, the easier it is for me to know where to look. I may have to ask you again for more information if I can't reproduce it. :)

    Also, I would really prefer to continue talking by e-mail. :) Please include the same information as I said to Anonymous. If you use anti-virus software, please include which one you use. Please tell me which operating system you use as well. Anything else you can think of that might help me, feel free to include it. :)

    This is all I can ask of people without asking too much (such as letting me debug DISE on their computer). :)

    ReplyDelete
  18. You can help me help you by trying a pre-alpha 43 build. If you still have the same problem, please don't comment on the blog, but e-mail me instead.

    ReplyDelete